Skip to main content

CommyPanel 0.4.2

A fix for installing and upgrading on Ubuntu 24.04.

Fixed​

  • The installer stopped at "Backing up and migrating the databases" on Ubuntu 24.04 with "Your Composer dependencies require a PHP version >= 8.4.1. You are running 8.3.6." The panel's libraries had been resolved on a machine with a newer PHP, and the Symfony 8 packages they pulled in need PHP 8.4. They are now on the Symfony 7.4 line, which runs on PHP 8.3 and newer. The release was run under PHP 8.3.36 to check. Debian 13 (PHP 8.4) and Ubuntu 26.04 (PHP 8.5) were not affected and still work.
  • Anyone on Ubuntu 24.04 who tried an earlier release saw the same failure, since the libraries were already in the lock in 0.2.x. A new install needs nothing special; run the installer again.

For developers​

  • The tests now run on Pest 4, because Pest 5 requires Symfony 8. A test checks that no locked production package needs more than PHP 8.3, and composer.json keeps Symfony 8 out with conflict entries.

Upgrading​

sudo commypanel upgrade